Skip to content

← Actionable
Low, CVSS 2.1

Apache Kylin Server-Side Request Forgery (SSRF) via /kylin/api/xxx/diag Endpoint

CVE-2024-48944GHSA-3v67-545x-ffc3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.kylin:kylin-common-server 5.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2024-48944: 0.64% estimated exploitation activity in the next 30 days; percentile 50.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. Through a kylin server, an attacker may forge a request to invoke "/kylin/api/xxx/diag" api on another internal host and possibly get leaked information. There are two preconditions: 1) The attacker has got admin access to a kylin server; 2) Another internal host has the "/kylin/api/xxx/diag" api endpoint open for service. This issue affects Apache Kylin: from 5.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3v67-545x-ffc3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-48944

Advisory: Apache Kylin Server-Side Request Forgery (SSRF) via `/kylin/api/xxx/diag` Endpoint
IDs: CVE-2024-48944, GHSA-3v67-545x-ffc3
Record: https://patchnext.com/advisories/cve-2024-48944 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.kylin:kylin-common-server 5.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.kylin:kylin-common-server: affected >= 5.0.0, < 5.0.2; fixed in 5.0.2

## Suggested inspection (read-only)
- Maven org.apache.kylin:kylin-common-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.kylin:kylin-common-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3v67-545x-ffc3 (GitHub-reviewed advisory GHSA-3v67-545x-ffc3 lists affected ranges: Maven org.apache.kylin:kylin-common-server >=5.0.0 <5.0.2)

Commands are suggestions: review each one before running it.

Loading voting…