Skip to content

← Actionable
High, CVSS 8.7amended

secp256k1-node allows private key extraction over ECDH

CVE-2024-48930GHSA-584q-6j8j-r5pm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (secp256k1 5.0.1, 4.0.4, 3.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm secp256k1

    Affected
    >= 5.0.0, <= 5.0.0>= 4.0.0, < 4.0.4<= 3.8.0
    Fixed in
    3.8.1, 5.0.1, 4.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-48930: 0.41% estimated exploitation activity in the next 30 days; percentile 34.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In elliptic-based version, loadUncompressedPublicKey has a check that the public key is on the curve: https://github.com/cryptocoinjs/secp256k1-node/blob/6d3474b81d073cc9c8cc8cfadb580c84f8df5248/lib/elliptic.js#L37-L39 loadCompressedPublicKey is, however, missing that check: https://github.com/cryptocoinjs/secp256k1-node/blob/6d3474b81d073cc9c8cc8cfadb580c84f8df5248/lib/elliptic.js#L17-L19 That allows the attacker to use public keys on low-cardinality curves to extract enough information to fully restore the private key from as little as 11 ECDH sessions, and very cheaply on compute power Other operations on public keys are also affected, including e.g. publicKeyVerify() incorrectly returning true on those invalid keys, and e.g. publicKeyTweakMul() also returning predictable outcomes allowing to restore the tweak Details The curve equation is Y^2 = X^3 + 7, and it restores Y from X in loadCompressedPublicKey, using Y = sqrt(X^3 + 7), but when there are no valid Y values…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-584q-6j8j-r5pm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-584q-6j8j-r5pm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-48930

Advisory: secp256k1-node allows private key extraction over ECDH
IDs: CVE-2024-48930, GHSA-584q-6j8j-r5pm
Record: https://patchnext.com/advisories/cve-2024-48930 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: secp256k1 5.0.1, 4.0.4, 3.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm secp256k1: affected >= 5.0.0, <= 5.0.0; >= 4.0.0, < 4.0.4; <= 3.8.0; fixed in 3.8.1, 5.0.1, 4.0.4

## Suggested inspection (read-only)
- `npm ls secp256k1 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on secp256k1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-584q-6j8j-r5pm (OSV record GHSA-584q-6j8j-r5pm lists affected ranges: npm secp256k1 >=5.0.0 =4.0.0 =0 <3.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-584q-6j8j-r5pm (GitHub-reviewed advisory GHSA-584q-6j8j-r5pm lists affected ranges: npm secp256k1 >=5.0.0 =4.0.0 =0 <=3.8.0)

Commands are suggestions: review each one before running it.

Loading voting…