Skip to content

← Actionable
High, CVSS 8.7

Kyverno's PolicyException objects can be created in any namespace by default

CVE-2024-48921GHSA-qjvc-p88j-j9rm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kyverno/kyverno 1.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-48921: 0.57% estimated exploitation activity in the next 30 days; percentile 47.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A kyverno ClusterPolicy, ie. "disallow-privileged-containers," can be overridden by the creation of a PolicyException in a random namespace. Details By design, PolicyExceptions are consumed from any namespace. Administrators may not recognize that this allows users with privileges to non-kyverno namespaces to create exceptions. PoC 1. Administrator creates "disallow-privileged-containers" ClusterPolicy that applies to resources in the namespace "ubuntu-restricted" 2. Cluster user creates a PolicyException object for "disallow-privileged-containers" in namespace "ubuntu-restricted" 3. Cluster user creates a pod with a privileged container in "ubuntu-restricted" 4. Cluster user escalates to root on the node from the privileged container Impact Administrators attempting to enforce cluster security through kyverno policies, but that allow less privileged users to create resources

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qjvc-p88j-j9rm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-48921

Advisory: Kyverno's PolicyException objects can be created in any namespace by default
IDs: CVE-2024-48921, GHSA-qjvc-p88j-j9rm
Record: https://patchnext.com/advisories/cve-2024-48921 (revision 1, source checked 26 Oct 2026, 15:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/kyverno/kyverno 1.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/kyverno/kyverno: affected < 1.13.0; fixed in 1.13.0

## Suggested inspection (read-only)
- Go github.com/kyverno/kyverno: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/kyverno/kyverno.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qjvc-p88j-j9rm (GitHub-reviewed advisory GHSA-qjvc-p88j-j9rm lists affected ranges: Go github.com/kyverno/kyverno >=0 <1.13.0)

Commands are suggestions: review each one before running it.

Loading voting…