Skip to content

← Actionable
Critical, CVSS 9.1amended

Vendure asset server plugin has local file read vulnerability with AssetServerPlugin & LocalAssetStorageStrategy

CVE-2024-48914GHSA-r9mq-3c9r-fmjq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vendure/asset-server-plugin 3.0.5, 2.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
EPSS
  • CVE-2024-48914: 60.42% estimated exploitation activity in the next 30 days; percentile 99.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Path traversal This vulnerability allows an attacker to craft a request which is able to traverse the server file system and retrieve the contents of arbitrary files, including sensitive data such as configuration files, environment variables, and other critical data stored on the server. From Rajesh Sharma who discovered the vulnerability: POC: curl --path-as-is http://localhost:3000/assets/../package.json gives you the content of package.json present in the local directory. The vulnerability stems from usage of decodedReqPath directly in path.join without performing any path normalization i.e path.normalize in node.js https://github.com/vendure-ecommerce/vendure/blob/801980e8f599c28c5059657a9d85dd03e3827992/packages/asset-server-plugin/src/plugin.ts#L352-L358 If the vendure service is behind some server like nginx, apache, etc. Path normalization is performed on the root server level but still the actual client's request path will be sent to vendure service but not the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r9mq-3c9r-fmjq

  2. Revision 1 · created ·

    Published from osv record GHSA-r9mq-3c9r-fmjq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-48914

Advisory: Vendure asset server plugin has local file read vulnerability with AssetServerPlugin & LocalAssetStorageStrategy
IDs: CVE-2024-48914, GHSA-r9mq-3c9r-fmjq
Record: https://patchnext.com/advisories/cve-2024-48914 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @vendure/asset-server-plugin 3.0.5, 2.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @vendure/asset-server-plugin: affected < 2.3.3; >= 3.0.0, < 3.0.5; fixed in 2.3.3, 3.0.5

## Suggested inspection (read-only)
- `npm ls @vendure/asset-server-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @vendure/asset-server-plugin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r9mq-3c9r-fmjq (OSV record GHSA-r9mq-3c9r-fmjq lists affected ranges: npm @vendure/asset-server-plugin >=0 =3.0.0 <3.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-r9mq-3c9r-fmjq (GitHub-reviewed advisory GHSA-r9mq-3c9r-fmjq lists affected ranges: npm @vendure/asset-server-plugin >=0 =3.0.0 <3.0.5)

Commands are suggestions: review each one before running it.

Loading voting…