lychee link checking action affected by arbitrary code injection in composite action
CVE-2024-48908GHSA-65rg-554r-9j5x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lycheeverse/lychee-action 2.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
GitHub Actions lycheeverse/lychee-action
- Affected
- < 2.0.2
- Fixed in
- 2.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-65rg-554r-9j5x lists affected ranges: GitHub Actions lycheeverse/lychee-action >=0 <2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2024-48908: 0.37% estimated exploitation activity in the next 30 days; percentile 30.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There is a potential attack of arbitrary code injection vulnerability in lychee-setup of the composite action at action.yml. Details The GitHub Action variable inputs.lycheeVersion can be used to execute arbitrary code in the context of the action. PoC The previous example will just print all the environment variables to the summary of the workflow, but an attacker could potentially use this vector to compromise the security of the target repository, even passing unnotice because the action will run normally. Impact Low
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-65rg-554r-9j5x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-48908 Advisory: lychee link checking action affected by arbitrary code injection in composite action IDs: CVE-2024-48908, GHSA-65rg-554r-9j5x Record: https://patchnext.com/advisories/cve-2024-48908 (revision 1, source checked 26 Oct 2026, 17:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lycheeverse/lychee-action 2.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - GitHub Actions lycheeverse/lychee-action: affected < 2.0.2; fixed in 2.0.2 ## Suggested inspection (read-only) - GitHub Actions lycheeverse/lychee-action: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lycheeverse/lychee-action. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-65rg-554r-9j5x (GitHub-reviewed advisory GHSA-65rg-554r-9j5x lists affected ranges: GitHub Actions lycheeverse/lychee-action >=0 <2.0.2) Commands are suggestions: review each one before running it.
Loading voting…