Mattermost Race Condition vulnerability
CVE-2024-48872GHSA-826h-p4c3-477p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.1.3, 10.0.3, 9.11.5, 9.5.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 10.0.0, < 10.0.3>= 9.11.0, < 9.11.5>= 9.5.0, < 9.5.13>= 10.1.0, < 10.1.3
- Fixed in
- 9.11.5, 9.5.13, 10.1.3, 10.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-826h-p4c3-477p lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.0.0 =9.11.0 =9.5.0 =10.1.0 <10.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2024-48872: 0.26% estimated exploitation activity in the next 30 days; percentile 17.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, and 9.5.x <= 9.5.12 fail to prevent concurrently checking and updating the failed login attempts. which allows an attacker to bypass of "Max failed attempts" restriction and send a big number of login attempts before being blocked via simultaneously sending multiple login requests
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-826h-p4c3-477p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-48872 Advisory: Mattermost Race Condition vulnerability IDs: CVE-2024-48872, GHSA-826h-p4c3-477p Record: https://patchnext.com/advisories/cve-2024-48872 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.1.3, 10.0.3, 9.11.5, 9.5.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 10.0.0, < 10.0.3; >= 9.11.0, < 9.11.5; >= 9.5.0, < 9.5.13; >= 10.1.0, < 10.1.3; fixed in 9.11.5, 9.5.13, 10.1.3, 10.0.3 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-826h-p4c3-477p (GitHub-reviewed advisory GHSA-826h-p4c3-477p lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.0.0 =9.11.0 =9.5.0 =10.1.0 <10.1.3) Commands are suggestions: review each one before running it.
Loading voting…