Skip to content

← Actionable
High, CVSS 7.7amended

LoLLMS Path Traversal vulnerability

CVE-2024-4881GHSA-p8h7-c8gw-6x8c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lollms 9.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lollms

    Affected
    < 9.5.0
    Fixed in
    9.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2024-4881: 0.89% estimated exploitation activity in the next 30 days; percentile 59.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A path traversal vulnerability exists in the parisneo/lollms application, affecting version 9.4.0 and potentially earlier versions, but fixed in version 9.5.0. The vulnerability arises due to improper validation of file paths between Windows and Linux environments, allowing attackers to traverse beyond the intended directory and read any file on the Windows system. Specifically, the application fails to adequately sanitize file paths containing backslashes (\), which can be exploited to access the root directory and read, or even delete, sensitive files. This issue was discovered in the context of the /userinfos endpoint, where a crafted request using backslashes to reference a file (e.g., \windows\win.ini) could result in unauthorized file access. The impact of this vulnerability includes the potential for attackers to access sensitive information such as environment variables, database files, and configuration files, which could lead to further compromise of the system.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p8h7-c8gw-6x8c

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-p8h7-c8gw-6x8c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-4881

Advisory: LoLLMS Path Traversal vulnerability
IDs: CVE-2024-4881, GHSA-p8h7-c8gw-6x8c
Record: https://patchnext.com/advisories/cve-2024-4881 (revision 3, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lollms 9.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lollms: affected < 9.5.0; fixed in 9.5.0

## Suggested inspection (read-only)
- `python -m pip show lollms`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lollms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p8h7-c8gw-6x8c (OSV record GHSA-p8h7-c8gw-6x8c lists affected ranges: PyPI lollms >=0 <9.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-p8h7-c8gw-6x8c (GitHub-reviewed advisory GHSA-p8h7-c8gw-6x8c lists affected ranges: PyPI lollms >=0 <9.5.0)

Commands are suggestions: review each one before running it.

Loading voting…