Skip to content

← Actionable
High, CVSS 7.7amended

Eugeny Tabby Sends Password Despite Host Key Verification Failure

CVE-2024-48460GHSA-8vq4-8hfp-29xh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tabby-ssh 1.0.214), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tabby-ssh

    Affected
    < 1.0.214
    Fixed in
    1.0.214

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2024-48460: 0.37% estimated exploitation activity in the next 30 days; percentile 30.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue in Eugeny Tabby 1.0.213 allows a remote attacker to obtain sensitive information via the server and sends the SSH username and password even when the host key verification fails.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8vq4-8hfp-29xh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8vq4-8hfp-29xh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-48460

Advisory: Eugeny Tabby Sends Password Despite Host Key Verification Failure
IDs: CVE-2024-48460, GHSA-8vq4-8hfp-29xh
Record: https://patchnext.com/advisories/cve-2024-48460 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tabby-ssh 1.0.214. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tabby-ssh: affected < 1.0.214; fixed in 1.0.214

## Suggested inspection (read-only)
- `npm ls tabby-ssh --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tabby-ssh.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8vq4-8hfp-29xh (OSV record GHSA-8vq4-8hfp-29xh lists affected ranges: npm tabby-ssh >=0 <1.0.214 (fixed))
- Verified: https://github.com/advisories/GHSA-8vq4-8hfp-29xh (GitHub-reviewed advisory GHSA-8vq4-8hfp-29xh lists affected ranges: npm tabby-ssh >=0 <1.0.214)

Commands are suggestions: review each one before running it.

Loading voting…