Skip to content

← Actionable
Medium, CVSS 6.6

Possible ReDoS vulnerability in HTTP Token authentication in Action Controller

CVE-2024-47887GHSA-vfg9-r3fq-jvx4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 7.2.1.1, 7.1.4.1, 7.0.8.5, 6.1.7.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems actionpack

    Affected
    >= 4.0.0, < 6.1.7.9>= 7.0.0, < 7.0.8.5>= 7.1.0, < 7.1.4.1>= 7.2.0, < 7.2.1.1
    Fixed in
    7.0.8.5, 7.1.4.1, 7.2.1.1, 6.1.7.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2024-47887: 1.04% estimated exploitation activity in the next 30 days; percentile 64.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a possible ReDoS vulnerability in Action Controller's HTTP Token authentication. This vulnerability has been assigned the CVE identifier CVE-2024-47887. Impact ------ For applications using HTTP Token authentication via authenticateorrequestwithhttptoken or similar, a carefully crafted header may cause header parsing to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade or apply the relevant patch immediately. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected. Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- Users on Ruby 3.2 are unaffected by this issue. Credits ------- Thanks to scyoon for reporting

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vfg9-r3fq-jvx4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47887

Advisory: Possible ReDoS vulnerability in HTTP Token authentication in Action Controller
IDs: CVE-2024-47887, GHSA-vfg9-r3fq-jvx4
Record: https://patchnext.com/advisories/cve-2024-47887 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: actionpack 7.2.1.1, 7.1.4.1, 7.0.8.5, 6.1.7.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems actionpack: affected >= 4.0.0, < 6.1.7.9; >= 7.0.0, < 7.0.8.5; >= 7.1.0, < 7.1.4.1; >= 7.2.0, < 7.2.1.1; fixed in 7.0.8.5, 7.1.4.1, 7.2.1.1, 6.1.7.9

## Suggested inspection (read-only)
- RubyGems actionpack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on actionpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vfg9-r3fq-jvx4 (GitHub-reviewed advisory GHSA-vfg9-r3fq-jvx4 lists affected ranges: RubyGems actionpack >=4.0.0 =7.0.0 =7.1.0 =7.2.0 <7.2.1.1)

Commands are suggestions: review each one before running it.

Loading voting…