Skip to content

← Actionable
Medium, CVSS 6.9

Extract has insufficient checks allowing attacker to create symlinks outside the extraction directory.

CVE-2024-47877GHSA-8rm2-93mq-jqhc

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/codeclysm/extract/v4

    Affected
    < 4.0.0
    Fixed in
    4.0.0
  • Go github.com/codeclysm/extract

    Affected
    <= 2.2.0
    Fixed in
    no fixed version recorded
  • Go github.com/codeclysm/extract/v3

    Affected
    <= 3.1.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-47877: 0.55% estimated exploitation activity in the next 30 days; percentile 45.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A maliciously crafted archive may allow an attacker to create a symlink outside the extraction target directory. Patches Please use version 4.0.0 or later github.com/codeclysm/extract/v4. Any previous version is affected by the bug. Workarounds No knows workarounds. Backward compatibility notes about upgrading to /v4 from /v3 If you're not using the extract.Extractor.FS interface, you will not face any breaking changes and upgrading should be as simple as changing the import to /v4. This should be the case for most of the userbase. If you're using the Extractor.FS interface, then upgrading to /v4 will require to implement the new methods that have been added: There should be no other breaking changes in the /v4 API.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8rm2-93mq-jqhc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47877

Advisory: Extract has insufficient checks allowing attacker to create symlinks outside the extraction directory.
IDs: CVE-2024-47877, GHSA-8rm2-93mq-jqhc
Record: https://patchnext.com/advisories/cve-2024-47877 (revision 1, source checked 26 Oct 2026, 15:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/codeclysm/extract/v4 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/codeclysm/extract/v4: affected < 4.0.0; fixed in 4.0.0
- Go github.com/codeclysm/extract: affected <= 2.2.0
- Go github.com/codeclysm/extract/v3: affected <= 3.1.1

## Suggested inspection (read-only)
- Go github.com/codeclysm/extract/v4: check the installed version with your package manager.
- Go github.com/codeclysm/extract: check the installed version with your package manager.
- Go github.com/codeclysm/extract/v3: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/codeclysm/extract/v4, github.com/codeclysm/extract, github.com/codeclysm/extract/v3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8rm2-93mq-jqhc (GitHub-reviewed advisory GHSA-8rm2-93mq-jqhc lists affected ranges: Go github.com/codeclysm/extract/v3 >=0 =0 =0 <=2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…