Skip to content

← Actionable
Medium, CVSS 4.8amended

Gradio has an XSS on every Gradio server via upload of HTML files, JS files, or SVG files

CVE-2024-47872GHSA-gvv6-33j7-884g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gradio 5.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gradio

    Affected
    < 5.0.0
    Fixed in
    5.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-47872: 0.28% estimated exploitation activity in the next 30 days; percentile 20.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? This vulnerability involves Cross-Site Scripting (XSS) on any Gradio server that allows file uploads. Authenticated users can upload files such as HTML, JavaScript, or SVG files containing malicious scripts. When other users download or view these files, the scripts will execute in their browser, allowing attackers to perform unauthorized actions or steal sensitive information from their sessions. This impacts any Gradio server that allows file uploads, particularly those using components that process or display user-uploaded files. Patches Yes, please upgrade to gradio=5 to address this issue. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? As a workaround, users can restrict the types of files that can be uploaded to the Gradio server by limiting uploads to non-executable file types such as images or text. Additionally, developers can implement server-side validation to sanitize…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gvv6-33j7-884g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-gvv6-33j7-884g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47872

Advisory: Gradio has an XSS on every Gradio server via upload of HTML files, JS files, or SVG files
IDs: CVE-2024-47872, GHSA-gvv6-33j7-884g
Record: https://patchnext.com/advisories/cve-2024-47872 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gradio 5.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gradio: affected < 5.0.0; fixed in 5.0.0

## Suggested inspection (read-only)
- `python -m pip show gradio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gradio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gvv6-33j7-884g (OSV record GHSA-gvv6-33j7-884g lists affected ranges: PyPI gradio >=0 <5.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-gvv6-33j7-884g (GitHub-reviewed advisory GHSA-gvv6-33j7-884g lists affected ranges: PyPI gradio >=0 <5.0.0)

Commands are suggestions: review each one before running it.

Loading voting…