Skip to content

← Actionable
High, CVSS 8.8amended

Gradio has a race condition in update_root_in_config may redirect user traffic

CVE-2024-47870GHSA-xh2x-3mrm-fwqm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gradio 5.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gradio

    Affected
    < 5.0.0
    Fixed in
    5.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-47870: 0.37% estimated exploitation activity in the next 30 days; percentile 31.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? This vulnerability involves a race condition in the updaterootinconfig function, allowing an attacker to modify the root URL used by the Gradio frontend to communicate with the backend. By exploiting this flaw, an attacker can redirect user traffic to a malicious server. This could lead to the interception of sensitive data such as authentication credentials or uploaded files. This impacts all users who connect to a Gradio server, especially those exposed to the internet, where malicious actors could exploit this race condition. Patches Yes, please upgrade to gradio=5 to address this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xh2x-3mrm-fwqm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xh2x-3mrm-fwqm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47870

Advisory: Gradio has a race condition in update_root_in_config may redirect user traffic
IDs: CVE-2024-47870, GHSA-xh2x-3mrm-fwqm
Record: https://patchnext.com/advisories/cve-2024-47870 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gradio 5.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gradio: affected < 5.0.0; fixed in 5.0.0

## Suggested inspection (read-only)
- `python -m pip show gradio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gradio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xh2x-3mrm-fwqm (OSV record GHSA-xh2x-3mrm-fwqm lists affected ranges: PyPI gradio >=0 <5.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-xh2x-3mrm-fwqm (GitHub-reviewed advisory GHSA-xh2x-3mrm-fwqm lists affected ranges: PyPI gradio >=0 <5.0.0)

Commands are suggestions: review each one before running it.

Loading voting…