Skip to content

← Actionable
Medium, CVSS 6.3amended

Gradio performs a non-constant-time comparison when comparing hashes

CVE-2024-47869GHSA-j757-pf57-f8r4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gradio 4.44.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gradio

    Affected
    < 4.44.0
    Fixed in
    4.44.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-47869: 0.29% estimated exploitation activity in the next 30 days; percentile 22.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? This vulnerability involves a timing attack in the way Gradio compares hashes for the analyticsdashboard function. Since the comparison is not done in constant time, an attacker could exploit this by measuring the response time of different requests to infer the correct hash byte-by-byte. This can lead to unauthorized access to the analytics dashboard, especially if the attacker can repeatedly query the system with different keys. Patches Yes, please upgrade to gradio4.44 to mitigate this issue. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? To mitigate the risk before applying the patch, developers can manually patch the analyticsdashboard dashboard to use a constant-time comparison function for comparing sensitive values, such as hashes. Alternatively, access to the analytics dashboard can be disabled.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j757-pf57-f8r4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j757-pf57-f8r4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47869

Advisory: Gradio performs a non-constant-time comparison when comparing hashes
IDs: CVE-2024-47869, GHSA-j757-pf57-f8r4
Record: https://patchnext.com/advisories/cve-2024-47869 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gradio 4.44.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gradio: affected < 4.44.0; fixed in 4.44.0

## Suggested inspection (read-only)
- `python -m pip show gradio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gradio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j757-pf57-f8r4 (OSV record GHSA-j757-pf57-f8r4 lists affected ranges: PyPI gradio >=0 <4.44.0 (fixed))
- Verified: https://github.com/advisories/GHSA-j757-pf57-f8r4 (GitHub-reviewed advisory GHSA-j757-pf57-f8r4 lists affected ranges: PyPI gradio >=0 <4.44.0)

Commands are suggestions: review each one before running it.

Loading voting…