Skip to content

← Actionable
Medium, CVSS 6.9amended

Gradio has several components with post-process steps allow arbitrary file leaks

CVE-2024-47868GHSA-4q3c-cj7g-jcwf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gradio 5.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI gradio

    Affected
    < 5.0.0
    Fixed in
    5.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-47868: 0.82% estimated exploitation activity in the next 30 days; percentile 57.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? This is a data validation vulnerability affecting several Gradio components, which allows arbitrary file leaks through the post-processing step. Attackers can exploit these components by crafting requests that bypass expected input constraints. This issue could lead to sensitive files being exposed to unauthorized users, especially when combined with other vulnerabilities, such as issue TOB-GRADIO-15. The components most at risk are those that return or handle file data. Vulnerable Components: 1. String to FileData: DownloadButton, Audio, ImageEditor, Video, Model3D, File, UploadButton. 2. Complex data to FileData: Chatbot, MultimodalTextbox. 3. Direct file read in preprocess: Code. 4. Dictionary converted to FileData: ParamViewer, Dataset. Exploit Scenarios: 1. A developer creates a Dropdown list that passes values to a DownloadButton. An attacker bypasses the allowed inputs, sends an arbitrary file path (like /etc/passwd),…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4q3c-cj7g-jcwf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4q3c-cj7g-jcwf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47868

Advisory: Gradio has several components with post-process steps allow arbitrary file leaks
IDs: CVE-2024-47868, GHSA-4q3c-cj7g-jcwf
Record: https://patchnext.com/advisories/cve-2024-47868 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gradio 5.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gradio: affected < 5.0.0; fixed in 5.0.0

## Suggested inspection (read-only)
- `python -m pip show gradio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gradio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4q3c-cj7g-jcwf (OSV record GHSA-4q3c-cj7g-jcwf lists affected ranges: PyPI gradio >=0 <5.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4q3c-cj7g-jcwf (GitHub-reviewed advisory GHSA-4q3c-cj7g-jcwf lists affected ranges: PyPI gradio >=0 <5.0.0)

Commands are suggestions: review each one before running it.

Loading voting…