Taipy has a Session Cookie without Secure and HTTPOnly flags
CVE-2024-47833GHSA-r3jq-4r5c-j9hp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (taipy 4.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI taipy
- Affected
- <= 3.1.1
- Fixed in
- 4.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r3jq-4r5c-j9hp lists affected ranges: PyPI taipy >=0 <4.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r3jq-4r5c-j9hp lists affected ranges: PyPI taipy >=0 <=3.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2024-47833: 0.25% estimated exploitation activity in the next 30 days; percentile 16.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Session cookie is without Secure and HTTPOnly flags. Details Please take a look at this part of code (PoC screenshot) or check code directly (provided in Occurrences section below) Occurrences: https://github.com/Avaiga/taipy/blob/develop/frontend/taipy-gui/src/components/Taipy/Navigate.tsx#L67 Proposed remediation: add Secure and HTTPOnly flags for cookies. It could be like this: document.cookie = tprh=${tprh};path=/;Secure;HttpOnly;; PoC Screenshot: Impact Secure: This flag indicates that the cookie should only be sent over secure HTTPS connections. Without this flag, the cookie will be sent over both HTTP and HTTPS connections, which could expose it to interception or tampering if the connection is not secure. HttpOnly: This flag prevents the cookie from being accessed by client-side JavaScript. It helps mitigate certain types of attacks, such as cross-site scripting (XSS), by preventing malicious scripts from accessing the cookie's value. References CWE-614: Sensitive…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r3jq-4r5c-j9hp
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-r3jq-4r5c-j9hp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47833 Advisory: Taipy has a Session Cookie without Secure and HTTPOnly flags IDs: CVE-2024-47833, GHSA-r3jq-4r5c-j9hp Record: https://patchnext.com/advisories/cve-2024-47833 (revision 3, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: taipy 4.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI taipy: affected <= 3.1.1; fixed in 4.0.0 ## Suggested inspection (read-only) - `python -m pip show taipy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on taipy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r3jq-4r5c-j9hp (OSV record GHSA-r3jq-4r5c-j9hp lists affected ranges: PyPI taipy >=0 <4.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r3jq-4r5c-j9hp (GitHub-reviewed advisory GHSA-r3jq-4r5c-j9hp lists affected ranges: PyPI taipy >=0 <=3.1.1) Commands are suggestions: review each one before running it.
Loading voting…