Denial of Service condition in Next.js image optimization
CVE-2024-47831GHSA-g77x-44xx-532m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 14.2.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 10.0.0, < 14.2.7
- Fixed in
- 14.2.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g77x-44xx-532m lists affected ranges: npm next >=10.0.0 <14.2.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g77x-44xx-532m lists affected ranges: npm next >=10.0.0 <14.2.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2024-47831: 0.73% estimated exploitation activity in the next 30 days; percentile 54.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The image optimization feature of Next.js contained a vulnerability which allowed for a potential Denial of Service (DoS) condition which could lead to excessive CPU consumption. Not affected: - The next.config.js file is configured with images.unoptimized set to true or images.loader set to a non-default value. - The Next.js application is hosted on Vercel. Patches This issue was fully patched in Next.js 14.2.7. We recommend that users upgrade to at least this version. Workarounds Ensure that the next.config.js file has either images.unoptimized, images.loader or images.loaderFile assigned. Credits Brandon Dahler (brandondahler), AWS Dimitrios Vlastaras
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g77x-44xx-532m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-g77x-44xx-532m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47831 Advisory: Denial of Service condition in Next.js image optimization IDs: CVE-2024-47831, GHSA-g77x-44xx-532m Record: https://patchnext.com/advisories/cve-2024-47831 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 14.2.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 10.0.0, < 14.2.7; fixed in 14.2.7 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g77x-44xx-532m (OSV record GHSA-g77x-44xx-532m lists affected ranges: npm next >=10.0.0 <14.2.7 (fixed)) - Verified: https://github.com/advisories/GHSA-g77x-44xx-532m (GitHub-reviewed advisory GHSA-g77x-44xx-532m lists affected ranges: npm next >=10.0.0 <14.2.7) Commands are suggestions: review each one before running it.
Loading voting…