Skip to content

← Actionable
Medium, CVSS 6.5amended

pnpm uses the md5 path shortening function causes packet paths to coincide, which causes indirect packet overwriting

CVE-2024-47829GHSA-8cc4-rfj6-fhg4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 10.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pnpm

    Affected
    < 10.0.0
    Fixed in
    10.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L
EPSS
  • CVE-2024-47829: 0.24% estimated exploitation activity in the next 30 days; percentile 14.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The path shortening function is used in pnpm: However, it uses the md5 function as a path shortening compression function, and if a collision occurs, it will result in the same storage path for two different libraries. Although the real names are under the package name /nodemodoules/, there are no version numbers for the libraries they refer to. In the diagram, we assume that two packages are called packageA and packageB, and that the first 90 digits of their package names must be the same, and that the hash value of the package names with versions must be the same. Then C is the package that they both reference, but with a different version number. (npm allows package names up to 214 bytes, so constructing such a collision package name is obvious.) Then hash(packageA@1.2.3)=hash(packageB@3.4.5). This results in the same path for the installation, and thus under the same directory. Although the package names under nodemodoules are the full paths again, they are shared with C. What is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8cc4-rfj6-fhg4

  2. Revision 1 · created ·

    Published from osv record GHSA-8cc4-rfj6-fhg4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47829

Advisory: pnpm uses the md5 path shortening function causes packet paths to coincide, which causes indirect packet overwriting
IDs: CVE-2024-47829, GHSA-8cc4-rfj6-fhg4
Record: https://patchnext.com/advisories/cve-2024-47829 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pnpm 10.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pnpm: affected < 10.0.0; fixed in 10.0.0

## Suggested inspection (read-only)
- `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pnpm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8cc4-rfj6-fhg4 (OSV record GHSA-8cc4-rfj6-fhg4 lists affected ranges: npm pnpm >=0 <10.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8cc4-rfj6-fhg4 (GitHub-reviewed advisory GHSA-8cc4-rfj6-fhg4 lists affected ranges: npm pnpm >=0 <10.0.0)

Commands are suggestions: review each one before running it.

Loading voting…