Skip to content

← Actionable
Medium, CVSS 4.2amended

Directus inserts access token from query string into logs

CVE-2024-47822GHSA-vw58-ph65-6rxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@directus/api 21.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-47822: 0.31% estimated exploitation activity in the next 30 days; percentile 24.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Access token from query string is not redacted and is potentially exposed in system logs which may be persisted. Details The access token in req.query is not redacted when the LOGSTYLE is set to raw. If these logs are not properly sanitized or protected, an attacker with access to it can potentially gain administrative control, leading to unauthorized data access and manipulation. PoC 1. Set LOGLEVEL="raw" in the environment. 2. Send a request with the accesstoken in the query string. 3. Notice that the accesstoken in req.query is not redacted. Impact It impacts systems where the LOGSTYLE is set to raw. The accesstoken in the query could potentially be a long-lived static token. Users with impacted systems should rotate their static tokens if they were provided using query string.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vw58-ph65-6rxp

  2. Revision 1 · created ·

    Published from osv record GHSA-vw58-ph65-6rxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47822

Advisory: Directus inserts access token from query string into logs
IDs: CVE-2024-47822, GHSA-vw58-ph65-6rxp
Record: https://patchnext.com/advisories/cve-2024-47822 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @directus/api 21.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @directus/api: affected < 21.0.0; fixed in 21.0.0

## Suggested inspection (read-only)
- `npm ls @directus/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @directus/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vw58-ph65-6rxp (OSV record GHSA-vw58-ph65-6rxp lists affected ranges: npm @directus/api >=0 <21.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vw58-ph65-6rxp (GitHub-reviewed advisory GHSA-vw58-ph65-6rxp lists affected ranges: npm @directus/api >=0 <21.0.0)

Commands are suggestions: review each one before running it.

Loading voting…