Jenkins OpenId Connect Authentication Plugin lacks issuer claim validation
CVE-2024-47807GHSA-8pjw-fff6-3mjv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:oic-auth 4.355.v3a), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:oic-auth
- Affected
- < 4.355.v3a
- Fixed in
- 4.355.v3a
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8pjw-fff6-3mjv lists affected ranges: Maven org.jenkins-ci.plugins:oic-auth >=0 <4.355.v3a
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-47807: 0.63% estimated exploitation activity in the next 30 days; percentile 50.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins OpenId Connect Authentication Plugin 4.354.v321ce67a1de8 and earlier does not check the iss (Issuer) claim of an ID Token during its authentication flow, a value that identifies the Originating Party (IdP). This vulnerability may allow attackers to subvert the authentication flow, potentially gaining administrator access to Jenkins. OpenId Connect Authentication Plugin 4.355.v3afbfcab96d4 checks the iss (Issuer) claim of an ID Token during its authentication flow when the Issuer is known.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8pjw-fff6-3mjv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47807 Advisory: Jenkins OpenId Connect Authentication Plugin lacks issuer claim validation IDs: CVE-2024-47807, GHSA-8pjw-fff6-3mjv Record: https://patchnext.com/advisories/cve-2024-47807 (revision 1, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:oic-auth 4.355.v3a. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:oic-auth: affected < 4.355.v3a; fixed in 4.355.v3a ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:oic-auth: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:oic-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8pjw-fff6-3mjv (GitHub-reviewed advisory GHSA-8pjw-fff6-3mjv lists affected ranges: Maven org.jenkins-ci.plugins:oic-auth >=0 <4.355.v3a) Commands are suggestions: review each one before running it.
Loading voting…