Skip to content

← Actionable
High, CVSS 7.6

Pomerium service account access token may grant unintended access to databroker API

CVE-2024-47616GHSA-r7rh-jww5-5fjr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pomerium/pomerium 0.27.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-47616: 0.58% estimated exploitation activity in the next 30 days; percentile 47.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact We've identified a vulnerability in the Pomerium databroker service API that may grant unintended access under specific conditions. This affects only certain Pomerium Zero and Pomerium Enterprise deployments. Who is affected? A Pomerium deployment is susceptible to this issue if all of the following conditions are met: - You have issued a service account access token using Pomerium Zero or Pomerium Enterprise. - The access token has an explicit expiration date in the future. - The core Pomerium databroker gRPC API is not otherwise secured by network access controls. If your deployment does not meet all of these conditions, you are not affected by this vulnerability. Details The Pomerium databroker service is responsible for managing all persistent Pomerium application state. Requests to the databroker service API are authorized by the presence of a JSON Web Token (JWT) signed by a key known by all Pomerium services in the same deployment. However, incomplete validation of this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r7rh-jww5-5fjr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47616

Advisory: Pomerium service account access token may grant unintended access to databroker API
IDs: CVE-2024-47616, GHSA-r7rh-jww5-5fjr
Record: https://patchnext.com/advisories/cve-2024-47616 (revision 1, source checked 26 Oct 2026, 15:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pomerium/pomerium 0.27.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pomerium/pomerium: affected < 0.27.1; fixed in 0.27.1

## Suggested inspection (read-only)
- Go github.com/pomerium/pomerium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pomerium/pomerium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r7rh-jww5-5fjr (GitHub-reviewed advisory GHSA-r7rh-jww5-5fjr lists affected ranges: Go github.com/pomerium/pomerium >=0 <0.27.1)

Commands are suggestions: review each one before running it.

Loading voting…