starcitizentools/citizen-skin vulnerable to stored, self-XSS in the "real name" field
CVE-2024-47536GHSA-62r2-gcxr-426x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (starcitizentools/citizen-skin 2.31.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist starcitizentools/citizen-skin
- Affected
- >= 2.6.3, < 2.31.0
- Fixed in
- 2.31.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-62r2-gcxr-426x lists affected ranges: Packagist starcitizentools/citizen-skin >=2.6.3 <2.31.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-47536: 0.46% estimated exploitation activity in the next 30 days; percentile 39.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A user with the editmyprivateinfo right or who can otherwise change their name can XSS themselves by setting their "real name" to an XSS payload. Details Here's the offending line: https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/d45c3d69f30863f622f16eb40dd41d3ca943454a/includes/Components/CitizenComponentUserInfo.php#L137 This was introduced in 717d16af35b10dab04d434aefddbf991fc8c168c PoC 1. Login 2. Go to Special:Preferences 3. Set the real name field to a string like <scriptalert("Admin with a propensity for self-XSSes")</script 4. Save your settings and use Citizen if it's not being used already Impact Any user who can change their name (whether it's through the editmyprivateinfo right or through other means) can add XSS payloads that trigger for themselves only.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-62r2-gcxr-426x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47536 Advisory: starcitizentools/citizen-skin vulnerable to stored, self-XSS in the "real name" field IDs: CVE-2024-47536, GHSA-62r2-gcxr-426x Record: https://patchnext.com/advisories/cve-2024-47536 (revision 1, source checked 26 Oct 2026, 14:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: starcitizentools/citizen-skin 2.31.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist starcitizentools/citizen-skin: affected >= 2.6.3, < 2.31.0; fixed in 2.31.0 ## Suggested inspection (read-only) - Packagist starcitizentools/citizen-skin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on starcitizentools/citizen-skin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-62r2-gcxr-426x (GitHub-reviewed advisory GHSA-62r2-gcxr-426x lists affected ranges: Packagist starcitizentools/citizen-skin >=2.6.3 <2.31.0) Commands are suggestions: review each one before running it.
Loading voting…