Skip to content

← Actionable
Medium, CVSS 5.4

Denial of Service attack on windows app using netty

CVE-2024-47535GHSA-xq3w-v528-46rv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-common 4.1.115.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2024-47535: 0.41% estimated exploitation activity in the next 30 days; percentile 35.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unsafe reading of environment file could potentially cause a denial of service in Netty. When loaded on an Windows application, Netty attemps to load a file that does not exist. If an attacker creates such a large file, the Netty application crash. Details When the library netty is loaded in a java windows application, the library tries to identify the system environnement in which it is executed. At this stage, Netty tries to load both /etc/os-release and /usr/lib/os-release even though it is in a Windows environment. <img width="364" alt="1" src="https://github.com/user-attachments/assets/9466b181-9394-45a3-b0e3-1dcf105def59" If netty finds this files, it reads them and loads them into memory. By default : - The JVM maximum memory size is set to 1 GB, - A non-privileged user can create a directory at C:\ and create files within it. <img width="340" alt="2" src="https://github.com/user-attachments/assets/43b359a2-5871-4592-ae2b-ffc40ac76831" <img width="523" alt="3"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xq3w-v528-46rv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47535

Advisory: Denial of Service attack on windows app using netty
IDs: CVE-2024-47535, GHSA-xq3w-v528-46rv
Record: https://patchnext.com/advisories/cve-2024-47535 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-common 4.1.115.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-common: affected <= 4.1.114.Final; fixed in 4.1.115.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-common: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xq3w-v528-46rv (GitHub-reviewed advisory GHSA-xq3w-v528-46rv lists affected ranges: Maven io.netty:netty-common >=0 <=4.1.114.Final)

Commands are suggestions: review each one before running it.

Loading voting…