Skip to content

← Actionable
Critical, CVSS 9.8amended

cobbler allows anyone to connect to cobbler XML-RPC server with known password and make changes

CVE-2024-47533GHSA-m26c-fcgh-cp6h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cobbler 3.3.7, 3.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI cobbler

    Affected
    >= 3.3.0, < 3.3.7>= 3.0.0, < 3.2.3
    Fixed in
    3.3.7, 3.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-47533: 4.00% estimated exploitation activity in the next 30 days; percentile 90.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary utils.get_shared_secret() always returns -1 - allows anyone to connect to cobbler XML-RPC as user '' password -1 and make any changes.

Details utils.py get_shared_secret: ``` def get_shared_secret() -> Union[str, int]: """ The 'web.ss' file is regenerated each time cobblerd restarts and is used to agree on shared secret interchange between the web server and cobblerd, and also the CLI and cobblerd, when username/password access is not required. For the CLI, this enables root users to avoid entering username/pass if on the Cobbler server. :return: The Cobbler secret which enables full access to Cobbler. """ try: with open("/var/lib/cobbler/web.ss", 'rb', encoding='utf-8') as fd: data = fd.read() except: return -1 return str(data).strip() ``` Always returns `-1` because of the following exception: ``` binary mode doesn't take an encoding argument ``` This appears to have been introduced by commit 32c5cada013dc8daa7320a8eda9932c2814742b0 and so affects versions 3.0.0+.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-m26c-fcgh-cp6h

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-m26c-fcgh-cp6h

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-m26c-fcgh-cp6h

  4. Revision 1 · created ·

    Published from osv record GHSA-m26c-fcgh-cp6h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47533

Advisory: cobbler allows anyone to connect to cobbler XML-RPC server with known password and make changes
IDs: CVE-2024-47533, GHSA-m26c-fcgh-cp6h
Record: https://patchnext.com/advisories/cve-2024-47533 (revision 4, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cobbler 3.3.7, 3.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI cobbler: affected >= 3.3.0, < 3.3.7; >= 3.0.0, < 3.2.3; fixed in 3.3.7, 3.2.3

## Suggested inspection (read-only)
- `python -m pip show cobbler`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cobbler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m26c-fcgh-cp6h (OSV record GHSA-m26c-fcgh-cp6h lists affected ranges: PyPI cobbler >=3.3.0 =3.0.0 <3.2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-m26c-fcgh-cp6h (GitHub-reviewed advisory GHSA-m26c-fcgh-cp6h lists affected ranges: PyPI cobbler >=3.3.0 =3.0.0 <3.2.3)

Commands are suggestions: review each one before running it.

Loading voting…