Skip to content

← Actionable
Medium, CVSS 5.9amended

OpenC3 stores passwords in clear text (GHSL-2024-129)

CVE-2024-47529GHSA-4xqv-47rm-37mm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openc3/tool-common 5.19.0; openc3 5.19.0; openc3 5.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-47529: 0.35% estimated exploitation activity in the next 30 days; percentile 29.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary OpenC3 COSMOS stores the password of a user unencrypted in the LocalStorage of a web browser. This makes the user password susceptible to exfiltration via Cross-site scripting (see GHSL-2024-128). Note: This CVE only affects Open Source edition, and not OpenC3 COSMOS Enterprise Edition Impact This issue may lead to Information Disclosure.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4xqv-47rm-37mm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4xqv-47rm-37mm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47529

Advisory: OpenC3 stores passwords in clear text (`GHSL-2024-129`)
IDs: CVE-2024-47529, GHSA-4xqv-47rm-37mm
Record: https://patchnext.com/advisories/cve-2024-47529 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openc3/tool-common 5.19.0; openc3 5.19.0; openc3 5.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openc3/tool-common: affected < 5.19.0; fixed in 5.19.0
- PyPI openc3: affected < 5.19.0; fixed in 5.19.0
- RubyGems openc3: affected < 5.19.0; fixed in 5.19.0

## Suggested inspection (read-only)
- `npm ls @openc3/tool-common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `python -m pip show openc3`: prints the installed version. Run with the environment that serves production active.
- RubyGems openc3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openc3/tool-common, openc3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4xqv-47rm-37mm (OSV record GHSA-4xqv-47rm-37mm lists affected ranges: RubyGems openc3 >=0 =0 =0 <5.19.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4xqv-47rm-37mm (GitHub-reviewed advisory GHSA-4xqv-47rm-37mm lists affected ranges: RubyGems openc3 >=0 =0 =0 <5.19.0)

Commands are suggestions: review each one before running it.

Loading voting…