Skip to content

← Actionable
Low, CVSS 1.8

LibreNMS vulnerable to Stored Cross-site Scripting via File Upload

CVE-2024-47528GHSA-x8gm-j36p-fppf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 24.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P · score source
EPSS
  • CVE-2024-47528: 0.41% estimated exploitation activity in the next 30 days; percentile 35.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Stored Cross-Site Scripting (XSS) can archive via Uploading a new Background for a Custom Map. Details Users with "admin" role can set background for a custom map, this allow the upload of SVG file that can contain XSS payload which will trigger onload. This led to Stored Cross-Site Scripting (XSS). PoC 1. Login using an Admin role account. 2. Go over to "$URL/maps/custom", the Manage Custom Maps. 3. Create a new map then choose to edit it. 4. Choose the "Set Background" option. 5. Choose to upload a SVG file that have this content. 6. Once uploaded, there should be a link to the SVG return in the POST request to the API "$URL/maps/custom/1/background". 7. Go over to that link on browser, should see a pop-up. Impact Attacker can use this to perform malicious java script code for malicious intent. This would impact other Admin role users and the Global Read role users. Normal users does not have permission to read the file, so they are not affected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x8gm-j36p-fppf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47528

Advisory: LibreNMS vulnerable to Stored Cross-site Scripting via File Upload
IDs: CVE-2024-47528, GHSA-x8gm-j36p-fppf
Record: https://patchnext.com/advisories/cve-2024-47528 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 24.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist librenms/librenms: affected < 24.9.0; fixed in 24.9.0

## Suggested inspection (read-only)
- Packagist librenms/librenms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on librenms/librenms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x8gm-j36p-fppf (GitHub-reviewed advisory GHSA-x8gm-j36p-fppf lists affected ranges: Packagist librenms/librenms >=0 <24.9.0)

Commands are suggestions: review each one before running it.

Loading voting…