Skip to content

← Actionable
Low, CVSS 1.9

LibreNMS has Stored Cross-site Scripting vulnerability in "Alert Templates" feature

CVE-2024-47526GHSA-gcgp-q2jq-fw52

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 24.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P · score source
EPSS
  • CVE-2024-47526: 0.48% estimated exploitation activity in the next 30 days; percentile 41.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Self Cross-Site Scripting (Self-XSS) vulnerability in the "Alert Templates" feature allows users to inject arbitrary JavaScript into the alert template's name. This script executes immediately upon submission but does not persist after a page refresh. Details The vulnerability occurs when creating an alert template in the LibreNMS interface. Although the application sanitizes the "name" field when storing it in the database, this newly created template is immediately added to the table without any sanitization being applied to the name, allowing users to inject arbitrary JavaScript. This script executes when the template is created but does not persist in the database, thus preventing stored XSS. For instance, the following payload can be used to exploit the vulnerability: The root cause of this vulnerability lies in the lack of sanitization of the "name" variable before it is rendered in the table. The vulnerability exists because the bootgrid function of the jQuery grid…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gcgp-q2jq-fw52

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47526

Advisory: LibreNMS has Stored Cross-site Scripting vulnerability in "Alert Templates" feature
IDs: CVE-2024-47526, GHSA-gcgp-q2jq-fw52
Record: https://patchnext.com/advisories/cve-2024-47526 (revision 1, source checked 26 Oct 2026, 14:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 24.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist librenms/librenms: affected < 24.9.0; fixed in 24.9.0

## Suggested inspection (read-only)
- Packagist librenms/librenms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on librenms/librenms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gcgp-q2jq-fw52 (GitHub-reviewed advisory GHSA-gcgp-q2jq-fw52 lists affected ranges: Packagist librenms/librenms >=0 <24.9.0)

Commands are suggestions: review each one before running it.

Loading voting…