LibreNMS has Stored Cross-site Scripting vulnerability in "Device Group" Name
CVE-2024-47524GHSA-fc38-2254-48g7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 24.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist librenms/librenms
- Affected
- < 24.9.0
- Fixed in
- 24.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fc38-2254-48g7 lists affected ranges: Packagist librenms/librenms >=0 <24.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2024-47524: 0.54% estimated exploitation activity in the next 30 days; percentile 45.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The application fail to sanitising inputs properly and rendering the code from user input to browser which allow an attacker to execute malicious javascript code. Details User with Admin role can create a Device Groups, the application did not properly sanitize the user input in the Device Groups name, when user see the detail of the Device Group, if java script code is inside the name of the Device Groups, its will be trigger. PoC 1. Login as an Admin role user. Then go over to "$URL/device-groups" 2. Create a new Device Group with this payload in their name 3. Go over to the detail page of that Device Groups, in this case "$URL/devices/group=2". Will see a pop-up. Impact Attacker can use this to perform malicious java script code for malicious intent. This would impact all users as anyone can have access to the detail page of the device group.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fc38-2254-48g7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47524 Advisory: LibreNMS has Stored Cross-site Scripting vulnerability in "Device Group" Name IDs: CVE-2024-47524, GHSA-fc38-2254-48g7 Record: https://patchnext.com/advisories/cve-2024-47524 (revision 1, source checked 26 Oct 2026, 14:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 24.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist librenms/librenms: affected < 24.9.0; fixed in 24.9.0 ## Suggested inspection (read-only) - Packagist librenms/librenms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on librenms/librenms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fc38-2254-48g7 (GitHub-reviewed advisory GHSA-fc38-2254-48g7 lists affected ranges: Packagist librenms/librenms >=0 <24.9.0) Commands are suggestions: review each one before running it.
Loading voting…