Filament has unvalidated ColorColumn and ColorEntry values that can be used for Cross-site Scripting
CVE-2024-47186GHSA-9h9q-qhxg-89xr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (filament/tables 3.2.115; filament/infolists 3.2.115), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist filament/tables
- Affected
- >= 3.0.0, < 3.2.115
- Fixed in
- 3.2.115
Packagist filament/infolists
- Affected
- >= 3.0.0, < 3.2.115
- Fixed in
- 3.2.115
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9h9q-qhxg-89xr lists affected ranges: Packagist filament/tables >=3.0.0 =3.0.0 <3.2.115
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-47186: 0.42% estimated exploitation activity in the next 30 days; percentile 36.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary If values passed to a ColorColumn or ColumnEntry are not valid and contain a specific set of characters, applications are vulnerable to XSS attack against a user who opens a page on which a color column or entry is rendered. Versions of Filament from v3.0.0 through v3.2.114 are affected. Please upgrade to Filament v3.2.115. PoC For example, using a value such as: Would get passed into the @style() Blade directive from Laravel to render the correct background color, where $state contains the value: Since Laravel does not escape special characters within the @style Blade directive, the effective output HTML would be: Creating the opportunity for arbitrary JS to run if it was stored in the database. Response This vulnerability (in ColorColumn only) was reported by @sv-LayZ, who reported the issue and patched the issue during the evening of 25/09/2024. Thank you Mattis. The review process concluded on 27/09/2024, which revealed the issue was also present in ColorEntry. This was…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9h9q-qhxg-89xr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47186 Advisory: Filament has unvalidated ColorColumn and ColorEntry values that can be used for Cross-site Scripting IDs: CVE-2024-47186, GHSA-9h9q-qhxg-89xr Record: https://patchnext.com/advisories/cve-2024-47186 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: filament/tables 3.2.115; filament/infolists 3.2.115. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist filament/tables: affected >= 3.0.0, < 3.2.115; fixed in 3.2.115 - Packagist filament/infolists: affected >= 3.0.0, < 3.2.115; fixed in 3.2.115 ## Suggested inspection (read-only) - Packagist filament/tables: check the installed version with your package manager. - Packagist filament/infolists: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on filament/tables, filament/infolists. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9h9q-qhxg-89xr (GitHub-reviewed advisory GHSA-9h9q-qhxg-89xr lists affected ranges: Packagist filament/tables >=3.0.0 =3.0.0 <3.2.115) Commands are suggestions: review each one before running it.
Loading voting…