Skip to content

← Actionable
High, CVSS 8.6amended

Parse Server's custom object ID allows to acquire role privileges

CVE-2024-47183GHSA-8xq9-g7ch-35hg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 7.3.0, 6.5.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    < 6.5.9>= 7.0.0, < 7.3.0
    Fixed in
    6.5.9, 7.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-47183: 0.42% estimated exploitation activity in the next 30 days; percentile 36.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If the Parse Server option allowCustomObjectId: true is set, an attacker that is allowed to create a new user can set a custom object ID for that new user that exploits the vulnerability and acquires privileges of a specific role. Patches Improved validation for custom user object IDs. Session tokens for existing users with an object ID that exploits the vulnerability are now rejected. Workarounds - Disable custom object IDs by setting allowCustomObjectId: false or not setting the option which defaults to false. - Use a Cloud Code Trigger to validate that a new user's object ID doesn't start with the prefix role:. References - https://github.com/parse-community/parse-server/security/advisories/GHSA-8xq9-g7ch-35hg - https://github.com/parse-community/parse-server/pull/9317 (fix for Parse Server 7) - https://github.com/parse-community/parse-server/pull/9318 (fix for Parse Server 6)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8xq9-g7ch-35hg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8xq9-g7ch-35hg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47183

Advisory: Parse Server's custom object ID allows to acquire role privileges
IDs: CVE-2024-47183, GHSA-8xq9-g7ch-35hg
Record: https://patchnext.com/advisories/cve-2024-47183 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 7.3.0, 6.5.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 6.5.9; >= 7.0.0, < 7.3.0; fixed in 6.5.9, 7.3.0

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8xq9-g7ch-35hg (OSV record GHSA-8xq9-g7ch-35hg lists affected ranges: npm parse-server >=0 =7.0.0 <7.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8xq9-g7ch-35hg (GitHub-reviewed advisory GHSA-8xq9-g7ch-35hg lists affected ranges: npm parse-server >=0 =7.0.0 <7.3.0)

Commands are suggestions: review each one before running it.

Loading voting…