Agnai File Disclosure Vulnerability: JSON via Path Traversal
CVE-2024-47170GHSA-h355-hm5h-cm8h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (agnai 1.0.330), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm agnai
- Affected
- < 1.0.330
- Fixed in
- 1.0.330
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h355-hm5h-cm8h lists affected ranges: npm agnai >=0 <1.0.330 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h355-hm5h-cm8h lists affected ranges: npm agnai >=0 <1.0.330
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-47170: 0.47% estimated exploitation activity in the next 30 days; percentile 40.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
CWE-35: Path Traversal https://cwe.mitre.org/data/definitions/35.html CVSSv3.1 4.3 - Medium CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N Summary A vulnerability has been discovered in Agnai that permits attackers to read arbitrary JSON files at attacker-chosen locations on the server. This issue can lead to unauthorized access to sensitive information and exposure of confidential configuration files. This only affects installations with JSONSTORAGE enabled which is intended to local/self-hosting only. Details & PoC This is a path traversal vulnerability. An attacker can exploit this vulnerability by sending a specially crafted request: In this example, the attacker retrieves the package.json file content from the server by manipulating the file path. The request is processed by the loadMessages handler in agnai/srv/api/json/index.ts and a file is read and returned to the client. The read filename is constructed using…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h355-hm5h-cm8h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h355-hm5h-cm8h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47170 Advisory: Agnai File Disclosure Vulnerability: JSON via Path Traversal IDs: CVE-2024-47170, GHSA-h355-hm5h-cm8h Record: https://patchnext.com/advisories/cve-2024-47170 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: agnai 1.0.330. A vendor fix does not mean a deployment is fixed. ## Affected components - npm agnai: affected < 1.0.330; fixed in 1.0.330 ## Suggested inspection (read-only) - `npm ls agnai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on agnai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h355-hm5h-cm8h (OSV record GHSA-h355-hm5h-cm8h lists affected ranges: npm agnai >=0 <1.0.330 (fixed)) - Verified: https://github.com/advisories/GHSA-h355-hm5h-cm8h (GitHub-reviewed advisory GHSA-h355-hm5h-cm8h lists affected ranges: npm agnai >=0 <1.0.330) Commands are suggestions: review each one before running it.
Loading voting…