Agnai vulnerable to Remote Code Execution via JS Upload using Directory Traversal
CVE-2024-47169GHSA-mpch-89gm-hm83
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (agnai 1.0.330), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm agnai
- Affected
- < 1.0.330
- Fixed in
- 1.0.330
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mpch-89gm-hm83 lists affected ranges: npm agnai >=0 <1.0.330 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mpch-89gm-hm83 lists affected ranges: npm agnai >=0 <1.0.330
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2024-47169: 0.78% estimated exploitation activity in the next 30 days; percentile 56.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A vulnerability has been discovered in Agnai that permits attackers to upload arbitrary files to attacker-chosen locations on the server, including JavaScript, enabling the execution of commands within those files. This issue could result in unauthorized access, full server compromise, data leakage, and other critical security threats. This does not affect: - agnai.chat - installations using S3-compatible storage - self-hosting that is not publicly exposed This DOES affect: - publicly hosted installs without S3-compatible storage CWEs CWE-35: Path Traversal CWE-434: Unrestricted Upload of File with Dangerous Type CVSS-4.0 - 9.0 - Critical CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H Description Path Traversal and Unrestricted Upload of File with Dangerous Type Path Traversal Location In the following file, the id parameter which is a remote-supplied parameter is not properly validated and sanitized.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mpch-89gm-hm83
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mpch-89gm-hm83
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47169 Advisory: Agnai vulnerable to Remote Code Execution via JS Upload using Directory Traversal IDs: CVE-2024-47169, GHSA-mpch-89gm-hm83 Record: https://patchnext.com/advisories/cve-2024-47169 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: agnai 1.0.330. A vendor fix does not mean a deployment is fixed. ## Affected components - npm agnai: affected < 1.0.330; fixed in 1.0.330 ## Suggested inspection (read-only) - `npm ls agnai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on agnai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mpch-89gm-hm83 (OSV record GHSA-mpch-89gm-hm83 lists affected ranges: npm agnai >=0 <1.0.330 (fixed)) - Verified: https://github.com/advisories/GHSA-mpch-89gm-hm83 (GitHub-reviewed advisory GHSA-mpch-89gm-hm83 lists affected ranges: npm agnai >=0 <1.0.330) Commands are suggestions: review each one before running it.
Loading voting…