XStream is vulnerable to a Denial of Service attack due to stack overflow from a manipulated binary input stream
CVE-2024-47072GHSA-hfq9-hggm-c56q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.thoughtworks.xstream:xstream 1.4.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.thoughtworks.xstream:xstream
- Affected
- < 1.4.21
- Fixed in
- 1.4.21
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hfq9-hggm-c56q lists affected ranges: Maven com.thoughtworks.xstream:xstream >=0 <1.4.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2024-47072: 2.00% estimated exploitation activity in the next 30 days; percentile 80.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The vulnerability may allow a remote attacker to terminate the application with a stack overflow error resulting in a denial of service only by manipulating the processed input stream when XStream is configured to use the BinaryStreamDriver. Patches XStream 1.4.21 detects the manipulation in the binary input stream causing the the stack overflow and raises an InputManipulationException instead. Workarounds The only solution is to catch the StackOverflowError in the client code calling XStream if XStream is configured to use the BinaryStreamDriver. References See full information about the nature of the vulnerability and the steps to reproduce it in XStream's documentation for CVE-2024-47072. Credits Alexis Challande of Trail Of Bits found and reported the issue to XStream and provided the required information to reproduce it.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hfq9-hggm-c56q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47072 Advisory: XStream is vulnerable to a Denial of Service attack due to stack overflow from a manipulated binary input stream IDs: CVE-2024-47072, GHSA-hfq9-hggm-c56q Record: https://patchnext.com/advisories/cve-2024-47072 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.thoughtworks.xstream:xstream 1.4.21. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.thoughtworks.xstream:xstream: affected < 1.4.21; fixed in 1.4.21 ## Suggested inspection (read-only) - Maven com.thoughtworks.xstream:xstream: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.thoughtworks.xstream:xstream. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hfq9-hggm-c56q (GitHub-reviewed advisory GHSA-hfq9-hggm-c56q lists affected ranges: Maven com.thoughtworks.xstream:xstream >=0 <1.4.21) Commands are suggestions: review each one before running it.
Loading voting…