Reflected Cross Site-Scripting (XSS) in Oveleon Cookiebar
CVE-2024-47069GHSA-296q-rj83-g9rq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (oveleon/contao-cookiebar 2.1.3, 1.16.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist oveleon/contao-cookiebar
- Affected
- < 1.16.3>= 2.0.0, < 2.1.3
- Fixed in
- 2.1.3, 1.16.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-296q-rj83-g9rq lists affected ranges: Packagist oveleon/contao-cookiebar >=0 =2.0.0 <2.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-47069: 0.45% estimated exploitation activity in the next 30 days; percentile 39.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
usd-2024-0009 | Reflected XSS in Oveleon Cookiebar Details Advisory ID: usd-2024-0009 Product: Cookiebar Affected Version: 2.X Vulnerability Type: CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') Security Risk: HIGH, CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N Vendor URL: https://www.usd.de/ Vendor acknowledged vulnerability: Yes Vendor Status: Fixed CVE Number: Not requested yet CVE Link: Not requested yet First Published: Published Last Update: 2024-07-29 Affected Component The block function in CookiebarController.php. Desciption Oveleon's Cookiebar is an extension for the popular Contao CMS. The block/locale endpoint does not properly sanitize the user-controlled locale input before including it in the backend's HTTP response, thereby causing reflected XSS. Proof of Concept The vulnerability could be triggered by entering the following Link: It is likely related to the following function in the Oveleon Cookiebar…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-296q-rj83-g9rq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47069 Advisory: Reflected Cross Site-Scripting (XSS) in Oveleon Cookiebar IDs: CVE-2024-47069, GHSA-296q-rj83-g9rq Record: https://patchnext.com/advisories/cve-2024-47069 (revision 1, source checked 26 Oct 2026, 14:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: oveleon/contao-cookiebar 2.1.3, 1.16.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist oveleon/contao-cookiebar: affected < 1.16.3; >= 2.0.0, < 2.1.3; fixed in 2.1.3, 1.16.3 ## Suggested inspection (read-only) - Packagist oveleon/contao-cookiebar: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on oveleon/contao-cookiebar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-296q-rj83-g9rq (GitHub-reviewed advisory GHSA-296q-rj83-g9rq lists affected ranges: Packagist oveleon/contao-cookiebar >=0 =2.0.0 <2.1.3) Commands are suggestions: review each one before running it.
Loading voting…