Skip to content

← Actionable
High, CVSS 8.3amended

DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS

CVE-2024-47068GHSA-gcx4-mw62-g8wm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rollup 4.22.4, 3.29.5, 2.79.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm rollup

    Affected
    >= 4.0.0, < 4.22.4>= 3.0.0, < 3.29.5< 2.79.2
    Fixed in
    3.29.5, 2.79.2, 4.22.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-47068: 0.74% estimated exploitation activity in the next 30 days; percentile 54.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary We discovered a DOM Clobbering vulnerability in rollup when bundling scripts that use import.meta.url or with plugins that emit and reference asset files from code in cjs/umd/iife format. The DOM Clobbering gadget can lead to cross-site scripting (XSS) in web pages where scriptless attacker-controlled HTML elements (e.g., an img tag with an unsanitized name attribute) are present. It's worth noting that we’ve identifed similar issues in other popular bundlers like Webpack (CVE-2024-43788), which might serve as a good reference. Details Backgrounds DOM Clobbering is a type of code-reuse attack where the attacker first embeds a piece of non-script, seemingly benign HTML markups in the webpage (e.g. through a post or comment) and leverages the gadgets (pieces of js code) living in the existing javascript code to transform it into executable code. More for information about DOM Clobbering, here are some references: [1] https://scnps.co/papers/sp23domclob.pdf [2]…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gcx4-mw62-g8wm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-gcx4-mw62-g8wm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47068

Advisory: DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS
IDs: CVE-2024-47068, GHSA-gcx4-mw62-g8wm
Record: https://patchnext.com/advisories/cve-2024-47068 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rollup 4.22.4, 3.29.5, 2.79.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm rollup: affected >= 4.0.0, < 4.22.4; >= 3.0.0, < 3.29.5; < 2.79.2; fixed in 3.29.5, 2.79.2, 4.22.4

## Suggested inspection (read-only)
- `npm ls rollup --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rollup.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gcx4-mw62-g8wm (OSV record GHSA-gcx4-mw62-g8wm lists affected ranges: npm rollup >=3.0.0 =4.0.0 =0 <2.79.2 (fixed))
- Verified: https://github.com/advisories/GHSA-gcx4-mw62-g8wm (GitHub-reviewed advisory GHSA-gcx4-mw62-g8wm lists affected ranges: npm rollup >=4.0.0 =3.0.0 =0 <2.79.2)

Commands are suggestions: review each one before running it.

Loading voting…