Skip to content

← Actionable
Medium, CVSS 6.3amended

lobe-chat implemented an insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964)

CVE-2024-47066GHSA-3fc8-2r3f-8wrg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@lobehub/chat 1.19.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:H · score source
EPSS
  • CVE-2024-47066: 11.86% estimated exploitation activity in the next 30 days; percentile 96.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SSRF protection implemented in https://github.com/lobehub/lobe-chat/blob/main/src/app/api/proxy/route.ts does not consider redirect and could be bypassed when attacker provides external malicious url which redirects to internal resources like private network or loopback address. PoC 1. Run lobe-chat in docker container. In my setup lobe-chat runs on 0.0.0.0:3210; 2. Create file dummy-server.js with the following content: And run as an example server inside of container [1] (or in containers private network). 3. Run in terminal to perform request to lobe-chat instance from [1] where body contains url of server which redirects to internal network (in my case it redirects according url parameter). 4. Observe in output of [2] 5. Attacker is able to perform SSRF attacks against lobe-chat despite https://github.com/lobehub/lobe-chat/blob/main/src/app/api/proxy/route.ts#L26 check. Fix recommendations: 1. Disable redirects - lobe-chat should consider explicitly disable redirects. 2.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3fc8-2r3f-8wrg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3fc8-2r3f-8wrg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47066

Advisory: lobe-chat implemented an insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964)
IDs: CVE-2024-47066, GHSA-3fc8-2r3f-8wrg
Record: https://patchnext.com/advisories/cve-2024-47066 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @lobehub/chat 1.19.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @lobehub/chat: affected <= 1.19.12; fixed in 1.19.13

## Suggested inspection (read-only)
- `npm ls @lobehub/chat --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @lobehub/chat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3fc8-2r3f-8wrg (OSV record GHSA-3fc8-2r3f-8wrg lists affected ranges: npm @lobehub/chat >=0 <1.19.13 (fixed))
- Verified: https://github.com/advisories/GHSA-3fc8-2r3f-8wrg (GitHub-reviewed advisory GHSA-3fc8-2r3f-8wrg lists affected ranges: npm @lobehub/chat >=0 <=1.19.12)

Commands are suggestions: review each one before running it.

Loading voting…