Skip to content

← Actionable
Medium, CVSS 6.9

Mautic allows users enumeration due to weak password login

CVE-2024-47059GHSA-8vff-35qm-qjvv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 5.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    >= 5.1.0, < 5.1.1
    Fixed in
    5.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-47059: 0.34% estimated exploitation activity in the next 30 days; percentile 27.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When logging in with the correct username and incorrect weak password, the user receives the notification, that their password is too weak. However when an incorrect username is provided along side with weak password, the application responds with ’Invalid credentials’ notification. This difference could be used to perform username enumeration. Patches Update to 5.1.1 or later. If you have any questions or comments about this advisory: Email us at security@mautic.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8vff-35qm-qjvv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47059

Advisory: Mautic allows users enumeration due to weak password login
IDs: CVE-2024-47059, GHSA-8vff-35qm-qjvv
Record: https://patchnext.com/advisories/cve-2024-47059 (revision 1, source checked 26 Oct 2026, 14:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core 5.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected >= 5.1.0, < 5.1.1; fixed in 5.1.1

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8vff-35qm-qjvv (GitHub-reviewed advisory GHSA-8vff-35qm-qjvv lists affected ranges: Packagist mautic/core >=5.1.0 <5.1.1)

Commands are suggestions: review each one before running it.

Loading voting…