Mautic segment cloning doesn't have a proper permission check
CVE-2024-47055GHSA-vph5-ghq3-q782
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 6.0.2, 5.2.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mautic/core
- Affected
- >= 5.0.0-alpha, < 5.2.6>= 6.0.0-alpha, < 6.0.2
- Fixed in
- 5.2.6, 6.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vph5-ghq3-q782 lists affected ranges: Packagist mautic/core >=5.0.0-alpha =6.0.0-alpha <6.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-47055: 0.26% estimated exploitation activity in the next 30 days; percentile 18.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary This advisory addresses a security vulnerability in Mautic related to the segment cloning functionality. This vulnerability allows any authenticated user to clone segments without proper authorization checks. Insecure Direct Object Reference (IDOR) / Missing Authorization: A missing authorization vulnerability exists in the cloneAction of the segment management. This allows an authenticated user to bypass intended permission restrictions and clone segments even if they lack the necessary permissions to create new ones. Mitigation Update Mautic to a version that implements proper authorization checks for the cloneAction within the ListController.php. Ensure that users attempting to clone segments possess the appropriate creation permissions. Workarounds None If you have any questions or comments about this advisory: Email us at security@mautic.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vph5-ghq3-q782
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-47055 Advisory: Mautic segment cloning doesn't have a proper permission check IDs: CVE-2024-47055, GHSA-vph5-ghq3-q782 Record: https://patchnext.com/advisories/cve-2024-47055 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mautic/core 6.0.2, 5.2.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mautic/core: affected >= 5.0.0-alpha, < 5.2.6; >= 6.0.0-alpha, < 6.0.2; fixed in 5.2.6, 6.0.2 ## Suggested inspection (read-only) - Packagist mautic/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mautic/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vph5-ghq3-q782 (GitHub-reviewed advisory GHSA-vph5-ghq3-q782 lists affected ranges: Packagist mautic/core >=5.0.0-alpha =6.0.0-alpha <6.0.2) Commands are suggestions: review each one before running it.
Loading voting…