Skip to content

← Actionable
High, CVSS 7.7

Mautic allows Improper Authorization in Reporting API

CVE-2024-47053GHSA-8xv7-g2q3-fqgc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 5.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    >= 1.0.1, < 5.2.3
    Fixed in
    5.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2024-47053: 0.74% estimated exploitation activity in the next 30 days; percentile 54.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary This advisory addresses an authorization vulnerability in Mautic's HTTP Basic Authentication implementation. This flaw could allow unauthorized access to sensitive report data. Improper Authorization: An authorization flaw exists in Mautic's API Authorization implementation. Any authenticated user, regardless of assigned roles or permissions, can access all reports and their associated data via the API. This bypasses the intended access controls governed by the "Reporting Permissions View Own" and "Reporting Permissions View Others" permissions, which should restrict access to non-System Reports. Mitigation Please update to Mautic 5.2.3 or later Workarounds Disable the API in Mautic. See documentation. References https://cwe.mitre.org/data/definitions/285.html https://docs.mautic.org/en/5.2/configuration/settings.html#api-settings If you have any questions or comments about this advisory: Email us at security@mautic.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8xv7-g2q3-fqgc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-47053

Advisory: Mautic allows Improper Authorization in Reporting API
IDs: CVE-2024-47053, GHSA-8xv7-g2q3-fqgc
Record: https://patchnext.com/advisories/cve-2024-47053 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core 5.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected >= 1.0.1, < 5.2.3; fixed in 5.2.3

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8xv7-g2q3-fqgc (GitHub-reviewed advisory GHSA-8xv7-g2q3-fqgc lists affected ranges: Packagist mautic/core >=1.0.1 <5.2.3)

Commands are suggestions: review each one before running it.

Loading voting…