Skip to content

← Actionable
Medium, CVSS 4.4amended

Electron vulnerable to Heap Buffer Overflow in NativeImage

CVE-2024-46993GHSA-6r2x-8pq8-9489

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 30.0.3, 29.3.3, 28.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electron

    Affected
    < 28.3.2>= 29.0.0-alpha.1, < 29.3.3>= 30.0.0-alpha.1, < 30.0.3
    Fixed in
    29.3.3, 28.3.2, 30.0.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.4 · CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2024-46993: 0.16% estimated exploitation activity in the next 30 days; percentile 4.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The nativeImage.createFromPath() and nativeImage.createFromBuffer() functions call a function downstream that is vulnerable to a heap buffer overflow. An Electron program that uses either of the affected functions is vulnerable to a buffer overflow if an attacker is in control of the image's height, width, and contents. Workaround There are no app-side workarounds for this issue. You must update your Electron version to be protected. Patches - v28.3.2 - v29.3.3 - v30.0.3 For More Information If you have any questions or comments about this advisory, email us at security@electronjs.org.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6r2x-8pq8-9489

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6r2x-8pq8-9489

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-46993

Advisory: Electron vulnerable to Heap Buffer Overflow in NativeImage
IDs: CVE-2024-46993, GHSA-6r2x-8pq8-9489
Record: https://patchnext.com/advisories/cve-2024-46993 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electron 30.0.3, 29.3.3, 28.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electron: affected < 28.3.2; >= 29.0.0-alpha.1, < 29.3.3; >= 30.0.0-alpha.1, < 30.0.3; fixed in 29.3.3, 28.3.2, 30.0.3

## Suggested inspection (read-only)
- `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electron.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6r2x-8pq8-9489 (OSV record GHSA-6r2x-8pq8-9489 lists affected ranges: npm electron >=0 =29.0.0-alpha.1 =30.0.0-alpha.1 <30.0.3 (fixed))
- Verified: https://github.com/advisories/GHSA-6r2x-8pq8-9489 (GitHub-reviewed advisory GHSA-6r2x-8pq8-9489 lists affected ranges: npm electron >=0 =29.0.0-alpha.1 =30.0.0-alpha.1 <30.0.3)

Commands are suggestions: review each one before running it.

Loading voting…