Directus vulnerable to SSRF Loopback IP filter bypass
CVE-2024-46990GHSA-68g8-c275-xf2m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.1.0, 10.13.3; @directus/api 22.1.1, 21.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- < 10.13.3>= 11.0.0, < 11.1.0
- Fixed in
- 11.1.0, 10.13.3
npm @directus/api
- Affected
- < 21.0.0>= 22.0.0, < 22.1.1
- Fixed in
- 21.0.0, 22.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-68g8-c275-xf2m lists affected ranges: npm directus >=0 =11.0.0 =0 =22.0.0 <22.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-68g8-c275-xf2m lists affected ranges: npm directus >=0 =11.0.0 =0 =22.0.0 <22.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2024-46990: 0.47% estimated exploitation activity in the next 30 days; percentile 40.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If you're relying on blocking access to localhost using the default 0.0.0.0 filter this can be bypassed using other registered loopback devices (like 127.0.0.2 - 127.127.127.127) Workaround You can block this bypass by manually adding the 127.0.0.0/8 CIDR range which will block access to any 127.X.X.X ip instead of just 127.0.0.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-68g8-c275-xf2m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-68g8-c275-xf2m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-46990 Advisory: Directus vulnerable to SSRF Loopback IP filter bypass IDs: CVE-2024-46990, GHSA-68g8-c275-xf2m Record: https://patchnext.com/advisories/cve-2024-46990 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 11.1.0, 10.13.3; @directus/api 22.1.1, 21.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected < 10.13.3; >= 11.0.0, < 11.1.0; fixed in 11.1.0, 10.13.3 - npm @directus/api: affected < 21.0.0; >= 22.0.0, < 22.1.1; fixed in 21.0.0, 22.1.1 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @directus/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus, @directus/api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-68g8-c275-xf2m (OSV record GHSA-68g8-c275-xf2m lists affected ranges: npm directus >=0 =11.0.0 =0 =22.0.0 <22.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-68g8-c275-xf2m (GitHub-reviewed advisory GHSA-68g8-c275-xf2m lists affected ranges: npm directus >=0 =11.0.0 =0 =22.0.0 <22.1.1) Commands are suggestions: review each one before running it.
Loading voting…