Camaleon CMS vulnerable to arbitrary path traversal (GHSL-2024-183)
CVE-2024-46987GHSA-cp65-5m9r-vc2c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (camaleon_cms 2.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems camaleon_cms
- Affected
- < 2.8.1
- Fixed in
- 2.8.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cp65-5m9r-vc2c lists affected ranges: RubyGems camaleon_cms >=0 <2.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-46987: 14.56% estimated exploitation activity in the next 30 days; percentile 96.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A path traversal vulnerability accessible via MediaController's downloadprivatefile method allows authenticated users to download any file on the web server Camaleon CMS is running on (depending on the file permissions). In the downloadprivatefile method: The file parameter is passed to the fetchfile method of the CamaleonCmsLocalUploader class (when files are uploaded locally): If the file exists it's passed back to the downloadprivatefile method where the file is sent to the user via sendfile. Proof of concept An authenticated user can download the /etc/passwd file by visiting an URL such as: https://<camaleon-host/admin/media/downloadprivatefile?file=../../../../../../etc/passwd Impact This issue may lead to Information Disclosure. Remediation Normalize file paths constructed from untrusted user input before using them and check that the resulting path is inside the targeted directory. Additionally, do not allow character sequences such as .. in untrusted input that is used to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cp65-5m9r-vc2c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-46987 Advisory: Camaleon CMS vulnerable to arbitrary path traversal (GHSL-2024-183) IDs: CVE-2024-46987, GHSA-cp65-5m9r-vc2c Record: https://patchnext.com/advisories/cve-2024-46987 (revision 1, source checked 26 Oct 2026, 15:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: camaleon_cms 2.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems camaleon_cms: affected < 2.8.1; fixed in 2.8.1 ## Suggested inspection (read-only) - RubyGems camaleon_cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on camaleon_cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cp65-5m9r-vc2c (GitHub-reviewed advisory GHSA-cp65-5m9r-vc2c lists affected ranges: RubyGems camaleon_cms >=0 <2.8.1) Commands are suggestions: review each one before running it.
Loading voting…