MindsDB Eval Injection vulnerability
CVE-2024-45848GHSA-9gq6-6936-885w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mindsdb 24.7.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mindsdb
- Affected
- >= 23.12.4.0, < 24.7.4.1
- Fixed in
- 24.7.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9gq6-6936-885w lists affected ranges: PyPI mindsdb >=23.12.4.0 <24.7.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9gq6-6936-885w lists affected ranges: PyPI mindsdb >=23.12.4.0 <24.7.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-45848: 0.85% estimated exploitation activity in the next 30 days; percentile 58.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An arbitrary code execution vulnerability exists in versions 23.12.4.0 up to 24.7.4.1 of the MindsDB platform, when the ChromaDB integration is installed on the server. If a specially crafted ‘INSERT’ query containing Python code is run against a database created with the ChromaDB engine, the code will be passed to an eval function and executed on the server.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9gq6-6936-885w
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9gq6-6936-885w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45848 Advisory: MindsDB Eval Injection vulnerability IDs: CVE-2024-45848, GHSA-9gq6-6936-885w Record: https://patchnext.com/advisories/cve-2024-45848 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mindsdb 24.7.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mindsdb: affected >= 23.12.4.0, < 24.7.4.1; fixed in 24.7.4.1 ## Suggested inspection (read-only) - `python -m pip show mindsdb`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mindsdb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9gq6-6936-885w (OSV record GHSA-9gq6-6936-885w lists affected ranges: PyPI mindsdb >=23.12.4.0 <24.7.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9gq6-6936-885w (GitHub-reviewed advisory GHSA-9gq6-6936-885w lists affected ranges: PyPI mindsdb >=23.12.4.0 <24.7.4.1) Commands are suggestions: review each one before running it.
Loading voting…