Vite DOM Clobbering gadget found in vite bundled scripts that leads to XSS
CVE-2024-45812GHSA-64vr-g452-qvp3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 5.4.6, 5.3.6, 5.2.14, 5.1.8, 4.5.4, 3.2.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vite
- Affected
- >= 4.0.0, < 4.5.4>= 5.4.0, < 5.4.6>= 5.3.0, < 5.3.6>= 5.2.0, < 5.2.14< 3.2.11>= 5.0.0, < 5.1.8
- Fixed in
- 5.2.14, 5.4.6, 5.3.6, 3.2.11, 4.5.4, 5.1.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-64vr-g452-qvp3 lists affected ranges: npm vite >=5.4.0 =5.3.0 =5.2.0 =4.0.0 =0 =5.0.0 <5.1.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-64vr-g452-qvp3 lists affected ranges: npm vite >=4.0.0 =5.4.0 =5.3.0 =5.2.0 =0 =5.0.0 <5.1.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-45812: 0.64% estimated exploitation activity in the next 30 days; percentile 50.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary We discovered a DOM Clobbering vulnerability in Vite when building scripts to cjs/iife/umd output format. The DOM Clobbering gadget in the module can lead to cross-site scripting (XSS) in web pages where scriptless attacker-controlled HTML elements (e.g., an img tag with an unsanitized name attribute) are present. Note that, we have identified similar security issues in Webpack: https://github.com/webpack/webpack/security/advisories/GHSA-4vvj-4cpr-p986 Details Backgrounds DOM Clobbering is a type of code-reuse attack where the attacker first embeds a piece of non-script, seemingly benign HTML markups in the webpage (e.g. through a post or comment) and leverages the gadgets (pieces of js code) living in the existing javascript code to transform it into executable code. More for information about DOM Clobbering, here are some references: [1] https://scnps.co/papers/sp23domclob.pdf [2] https://research.securitum.com/xss-in-amp4email-dom-clobbering/ Gadgets found in Vite We have…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-64vr-g452-qvp3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-64vr-g452-qvp3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45812 Advisory: Vite DOM Clobbering gadget found in vite bundled scripts that leads to XSS IDs: CVE-2024-45812, GHSA-64vr-g452-qvp3 Record: https://patchnext.com/advisories/cve-2024-45812 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vite 5.4.6, 5.3.6, 5.2.14, 5.1.8, 4.5.4, 3.2.11. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vite: affected >= 4.0.0, < 4.5.4; >= 5.4.0, < 5.4.6; >= 5.3.0, < 5.3.6; >= 5.2.0, < 5.2.14; < 3.2.11; >= 5.0.0, < 5.1.8; fixed in 5.2.14, 5.4.6, 5.3.6, 3.2.11, 4.5.4, 5.1.8 ## Suggested inspection (read-only) - `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vite. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-64vr-g452-qvp3 (OSV record GHSA-64vr-g452-qvp3 lists affected ranges: npm vite >=5.4.0 =5.3.0 =5.2.0 =4.0.0 =0 =5.0.0 <5.1.8 (fixed)) - Verified: https://github.com/advisories/GHSA-64vr-g452-qvp3 (GitHub-reviewed advisory GHSA-64vr-g452-qvp3 lists affected ranges: npm vite >=4.0.0 =5.4.0 =5.3.0 =5.2.0 =0 =5.0.0 <5.1.8) Commands are suggestions: review each one before running it.
Loading voting…