Skip to content

← Actionable
Medium, CVSS 5.1

Wire UI has a JS XSS Vulnerability on route /wireui/button?label=Content

CVE-2024-45803GHSA-rw5h-g8xq-6877

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wireui/wireui 2.1.3, 1.19.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist wireui/wireui

    Affected
    < 1.19.3>= 2.0.0, < 2.1.3
    Fixed in
    1.19.3, 2.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-45803: 0.42% estimated exploitation activity in the next 30 days; percentile 35.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A potential Cross-Site Scripting (XSS) vulnerability has been identified in the /wireui/button endpoint, specifically through the label query parameter. Malicious actors could exploit this vulnerability by injecting JavaScript into the label parameter, leading to the execution of arbitrary code in the victim's browser. Details The /wireui/button endpoint dynamically renders button labels based on user-provided input via the label query parameter. Due to insufficient sanitization or escaping of this input, an attacker can inject malicious JavaScript. The following URL demonstrates the vulnerability: By crafting such a request, an attacker can inject arbitrary code that will be executed by the browser when the endpoint is accessed. Proof of Concept (PoC) To demonstrate the vulnerability, visit the following URL: Upon loading the page, the injected JavaScript will execute, displaying an alert with the message "1." This confirms the vulnerability and highlights that user input is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rw5h-g8xq-6877

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45803

Advisory: Wire UI has a JS XSS Vulnerability on route /wireui/button?label=Content
IDs: CVE-2024-45803, GHSA-rw5h-g8xq-6877
Record: https://patchnext.com/advisories/cve-2024-45803 (revision 1, source checked 26 Oct 2026, 14:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wireui/wireui 2.1.3, 1.19.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist wireui/wireui: affected < 1.19.3; >= 2.0.0, < 2.1.3; fixed in 1.19.3, 2.1.3

## Suggested inspection (read-only)
- Packagist wireui/wireui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wireui/wireui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rw5h-g8xq-6877 (GitHub-reviewed advisory GHSA-rw5h-g8xq-6877 lists affected ranges: Packagist wireui/wireui >=0 =2.0.0 <2.1.3)

Commands are suggestions: review each one before running it.

Loading voting…