Skip to content

← Actionable
Medium, CVSS 5.1amended

Prevent XSS from Confidant API call

CVE-2024-45793GHSA-rxq8-q85f-m866

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (confidant 6.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-45793: 0.36% estimated exploitation activity in the next 30 days; percentile 29.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? Potential XSS from API calls below: GET <app/v1/credentials GET <app/v1/credentials/<id GET <app/v1/archive/credentials/<id GET <app/v1/archive/credentials POST <app/v1/credentials PUT <app/v1/credentials/<id PUT <app/v1/credentials/<id/<torevision GET <app/v1/services GET <app/v1/services/<id GET <app/v1/archive/services/<id GET <app/v1/archive/services PUT <app/v1/services/<id PUT <app/v1/services/<id/<torevision Stored XSS that can only be used as a stored HTML injection. The attacker needs to be authenticated and have privileges to create new credentials, but could use this to show information and run scripts to other users into the same Confidant instance. Patches Has the problem been patched? What versions should users upgrade to? yes, version 6.6.2 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? NO References Are there any links users can visit to find out more?…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rxq8-q85f-m866

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rxq8-q85f-m866

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45793

Advisory: Prevent XSS from Confidant API call
IDs: CVE-2024-45793, GHSA-rxq8-q85f-m866
Record: https://patchnext.com/advisories/cve-2024-45793 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: confidant 6.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI confidant: affected < 6.6.2; fixed in 6.6.2

## Suggested inspection (read-only)
- `python -m pip show confidant`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on confidant.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rxq8-q85f-m866 (OSV record GHSA-rxq8-q85f-m866 lists affected ranges: PyPI confidant >=0 <6.6.2 (fixed))
- Verified: https://github.com/advisories/GHSA-rxq8-q85f-m866 (GitHub-reviewed advisory GHSA-rxq8-q85f-m866 lists affected ranges: PyPI confidant >=0 <6.6.2)

Commands are suggestions: review each one before running it.

Loading voting…