Apache Airflow: Sensitive configuration values are not masked in the logs by default
CVE-2024-45784GHSA-46c3-5xc5-wwhv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (airflow 2.10.3; apache-airflow 2.10.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI airflow
- Affected
- < 2.10.3
- Fixed in
- 2.10.3
PyPI apache-airflow
- Affected
- < 2.10.3
- Fixed in
- 2.10.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-46c3-5xc5-wwhv lists affected ranges: PyPI airflow >=0 <2.10.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2024-182 lists affected ranges: PyPI apache-airflow >=0 <2.10.3 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-46c3-5xc5-wwhv lists affected ranges: PyPI airflow >=0 <2.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-45784: 1.34% estimated exploitation activity in the next 30 days; percentile 71.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Airflow versions before 2.10.3 contain a vulnerability that could expose sensitive configuration variables in task logs. This vulnerability allows DAG authors to unintentionally or intentionally log sensitive configuration variables. Unauthorized users could access these logs, potentially exposing critical data that could be exploited to compromise the security of the Airflow deployment. In version 2.10.3, secrets are now masked in task logs to prevent sensitive configuration variables from being exposed in the logging output. Users should upgrade to Airflow 2.10.3 or the latest version to eliminate this vulnerability. If you suspect that DAG authors could have logged the secret values to the logs and that your logs are not additionally protected, it is also recommended that you update those secrets.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-46c3-5xc5-wwhv
- Revision 2 · amended ·
Amended from osv record PYSEC-2024-182
- Revision 1 · created ·
Published from osv record GHSA-46c3-5xc5-wwhv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45784 Advisory: Apache Airflow: Sensitive configuration values are not masked in the logs by default IDs: CVE-2024-45784, GHSA-46c3-5xc5-wwhv Record: https://patchnext.com/advisories/cve-2024-45784 (revision 3, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: airflow 2.10.3; apache-airflow 2.10.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI airflow: affected < 2.10.3; fixed in 2.10.3 - PyPI apache-airflow: affected < 2.10.3; fixed in 2.10.3 ## Suggested inspection (read-only) - `python -m pip show airflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on airflow, apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-46c3-5xc5-wwhv (OSV record GHSA-46c3-5xc5-wwhv lists affected ranges: PyPI airflow >=0 <2.10.3 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2024-182 (OSV record PYSEC-2024-182 lists affected ranges: PyPI apache-airflow >=0 <2.10.3 (fixed)) - Verified: https://github.com/advisories/GHSA-46c3-5xc5-wwhv (GitHub-reviewed advisory GHSA-46c3-5xc5-wwhv lists affected ranges: PyPI airflow >=0 <2.10.3) Commands are suggestions: review each one before running it.
Loading voting…