Skip to content

← Actionable
Medium, CVSS 6.3

Puma's header normalization allows for client to clobber proxy set headers

CVE-2024-45614GHSA-9hf4-67fc-4vf4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (puma 6.4.3, 5.6.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems puma

    Affected
    < 5.6.9>= 6.0.0, < 6.4.3
    Fixed in
    5.6.9, 6.4.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-45614: 0.64% estimated exploitation activity in the next 30 days; percentile 50.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Clients could clobber values set by intermediate proxies (such as X-Forwarded-For) by providing a underscore version of the same header (X-ForwardedFor). Any users trusting headers set by their proxy may be affected. Attackers may be able to downgrade connections to HTTP (non-SSL) or redirect responses, which could cause confidentiality leaks if combined with a separate MITM attack. Patches v6.4.3/v5.6.9 now discards any headers using underscores if the non-underscore version also exists. Effectively, allowing the proxy defined headers to always win. Workarounds Nginx has a underscoresinheaders configuration variable to discard these headers at the proxy level. Any users that are implicitly trusting the proxy defined headers for security or availability should immediately cease doing so until upgraded to the fixed versions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9hf4-67fc-4vf4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45614

Advisory: Puma's header normalization allows for client to clobber proxy set headers
IDs: CVE-2024-45614, GHSA-9hf4-67fc-4vf4
Record: https://patchnext.com/advisories/cve-2024-45614 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: puma 6.4.3, 5.6.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems puma: affected < 5.6.9; >= 6.0.0, < 6.4.3; fixed in 5.6.9, 6.4.3

## Suggested inspection (read-only)
- RubyGems puma: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on puma.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9hf4-67fc-4vf4 (GitHub-reviewed advisory GHSA-9hf4-67fc-4vf4 lists affected ranges: RubyGems puma >=0 =6.0.0 <6.4.3)

Commands are suggestions: review each one before running it.

Loading voting…