Skip to content

← Actionable
High, CVSS 7.1amended

Sentry improperly authorizes muting of alert rules

CVE-2024-45606GHSA-v345-w9f2-mpm5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 24.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI sentry

    Affected
    >= 23.4.0, < 24.9.0
    Fixed in
    24.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-45606: 0.36% estimated exploitation activity in the next 30 days; percentile 29.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user can mute alert rules from arbitrary organizations and projects given a known given rule ID. The user does not need to be a member of the organization or have permissions on the project. In our review, we have identified no instances where alerts have been muted by unauthorized parties. Patches A patch was issued to ensure authorization checks are properly scoped on requests to mute alert rules. Authenticated users who do not have the necessary permissions are no longer able to mute alerts. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher. Affected Versions The rule mute feature was generally available as of 23.6.0 but users with early access may have had the feature as of 23.4.0. Update As of 2024-10-25 and after additional we've updated the Severity scoring to reduce Privileged Required from Low to None and Integrity from High to Low. Thanks again to @emanuelbeni for the correction on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v345-w9f2-mpm5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-v345-w9f2-mpm5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45606

Advisory: Sentry improperly authorizes muting of alert rules
IDs: CVE-2024-45606, GHSA-v345-w9f2-mpm5
Record: https://patchnext.com/advisories/cve-2024-45606 (revision 3, source checked 26 Oct 2026, 13:23 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sentry 24.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI sentry: affected >= 23.4.0, < 24.9.0; fixed in 24.9.0

## Suggested inspection (read-only)
- `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sentry.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v345-w9f2-mpm5 (OSV record GHSA-v345-w9f2-mpm5 lists affected ranges: PyPI sentry >=23.4.0 <24.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v345-w9f2-mpm5 (GitHub-reviewed advisory GHSA-v345-w9f2-mpm5 lists affected ranges: PyPI sentry >=23.4.0 <24.9.0)

Commands are suggestions: review each one before running it.

Loading voting…