Skip to content

← Actionable
High, CVSS 8.7amended

Mesop has a local file Inclusion via static file serving functionality

CVE-2024-45601GHSA-pmv9-3xqp-8w42

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mesop 0.12.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mesop

    Affected
    >= 0.9.0, < 0.12.4
    Fixed in
    0.12.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-45601: 0.28% estimated exploitation activity in the next 30 days; percentile 20.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability has been discovered and fixed in Mesop that could potentially allow unauthorized access to files on the server hosting the Mesop application. The vulnerability was related to insufficient input validation in a specific endpoint. This could have allowed an attacker to access files not intended to be served. Users are strongly advised to update to the latest version of Mesop immediately. The latest version includes a fix for this vulnerability. We would like to thank @Letm3through for reporting this issue and proposing mitigations to address this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pmv9-3xqp-8w42

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-pmv9-3xqp-8w42

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45601

Advisory: Mesop has a local file Inclusion via static file serving functionality
IDs: CVE-2024-45601, GHSA-pmv9-3xqp-8w42
Record: https://patchnext.com/advisories/cve-2024-45601 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mesop 0.12.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mesop: affected >= 0.9.0, < 0.12.4; fixed in 0.12.4

## Suggested inspection (read-only)
- `python -m pip show mesop`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mesop.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pmv9-3xqp-8w42 (OSV record GHSA-pmv9-3xqp-8w42 lists affected ranges: PyPI mesop >=0.9.0 <0.12.4 (fixed))
- Verified: https://github.com/advisories/GHSA-pmv9-3xqp-8w42 (GitHub-reviewed advisory GHSA-pmv9-3xqp-8w42 lists affected ranges: PyPI mesop >=0.9.0 <0.12.4)

Commands are suggestions: review each one before running it.

Loading voting…