Skip to content

← Actionable
Medium, CVSS 6.9

XWiki Platform document history including authors of any page exposed to unauthorized actors

CVE-2024-45591GHSA-pvmm-55r5-g3mm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-rest-server 16.3.0-rc-1, 15.10.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-pvmm-55r5-g3mm lists affected ranges: Maven org.xwiki.platform:xwiki-platform-rest-server >=1.8.0 =16.0.0-rc-1 <16.3.0-rc-1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-45591: 3.42% estimated exploitation activity in the next 30 days; percentile 88.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The REST API exposes the history of any page in XWiki of which the attacker knows the name. The exposed information includes for each modification of the page the time of the modification, the version number, the author of the modification (both username and displayed name) and the version comment. This information is exposed regardless of the rights setup, and even when the wiki is configured to be fully private. On a private wiki, this can be tested by accessing /xwiki/rest/wikis/xwiki/spaces/Main/pages/WebHome/history, if this shows the history of the main page then the installation is vulnerable. Patches This has been patched in XWiki 15.10.9 and XWiki 16.3.0RC1. Workarounds There aren't any known workarounds apart from upgrading to a fixed version. References https://jira.xwiki.org/browse/XWIKI-22052 https://github.com/xwiki/xwiki-platform/commit/9cbca9808300797c67779bb9a665d85cf9e3d4b8

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pvmm-55r5-g3mm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45591

Advisory: XWiki Platform document history including authors of any page exposed to unauthorized actors
IDs: CVE-2024-45591, GHSA-pvmm-55r5-g3mm
Record: https://patchnext.com/advisories/cve-2024-45591 (revision 1, source checked 26 Oct 2026, 16:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-rest-server 16.3.0-rc-1, 15.10.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-rest-server: affected >= 1.8.0, < 15.10.9; >= 16.0.0-rc-1, < 16.3.0-rc-1; fixed in 15.10.9, 16.3.0-rc-1

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-rest-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-rest-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pvmm-55r5-g3mm (GitHub-reviewed advisory GHSA-pvmm-55r5-g3mm lists affected ranges: Maven org.xwiki.platform:xwiki-platform-rest-server >=1.8.0 =16.0.0-rc-1 <16.3.0-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…